CAMO Software

Webinars


What are the system requirements?

PC-based attendees:

  • Windows 2000, XP, 2003 Server, or Vista

  • Internet Explorer 5.0 or later, Netscape Navigator 6.0 or later or Firefox 1.0 or later

 

Macintosh-based attendees:

  • Mac OS X 10.3.9 or newer

  • Safari 1.3 or newer, or Firefox 1.5.0.2 or newer


others...